Choisir une catégorie
Aperçu Aide Contact
print article

Qu'est-ce que le 1&1 Support Prolongé PHP ?

Valable pour les offres de type Hébergement Mutualisé Linux et Serveur Dédié Clé-en-main.

Cet article vous explique ce qu'est le 1&1 Support Prolongé PHP et comment vérifier si vous en avez besoin.

Lorsqu'une version de PHP est devenue obsolète, celle-ci est retirée des offres qui peuvent être souscrites sur notre site Internet.

L'option 1&1 Support Prolongé PHP nous permet de continuer à proposer une version de PHP devenue obsolète dans les contrats existants qui disposent et utilisent encore cette version.

Les versions de PHP devenues obsolètes que nous continuons à mettre à disposition via le 1&1 Support Prolongé PHP sont :

  • PHP 4
  • PHP 5.2
  • PHP 5.4
  • PHP 5.5

Si vous utilisez une version devenue obsolète, vous êtes automatiquement informé par e-mail (envoyé à l'adresse e-mail de contact du compte client) que l'utilisation restera possible via l'activation de l'option 1&1 Support Prolongé PHP. Celle-ci sera activée automatiquement.


Pourquoi suis-je facturé pour le 1&1 Support Prolongé PHP ?

L'option 1&1 Support Prolongé PHP est automatiquement activée dès lors que votre espace Web continue à utiliser une version de PHP devenue osolète.

Nous vous adressons automatiquement un e-mail avant activation et facturation de cette option. L'e-mail est automatiquement envoyé à l'adresse e-mail de contact du compte client.

Pour vérifier si vos scripts peuvent fonctionner avec une version actuelle de PHP, suivez les indications fournies dans cet article.

Si vos scripts fonctionnent avec une version actuelle de PHP, vous pouvez changer la version directement depuis l'Espace Client 1&1 en cliquant sur le bouton Déterminer la version PHP. Une procédure détaillée est disponible dans cet article.


Pourquoi est-ce que je suis toujours facturé pour le 1&1 Support Prolongé PHP alors que j'ai choisi un version actuelle de PHP pour tous mes domaines ?

C'est que vous n'avez probablement pas vu le message vous indiquant qu'il vous faut résilier l'option si vous n'en avez plus besoin. Suivez les indications fournies dans cet article pour procéder à la résiliation de l'option 1&1 Support Prolongé PHP.


Quand est-ce que le 1&1 Support Prolongé PHP est activé ?

Le 1&1 Support Prolongé PHP est activé dès lors qu'une version de PHP devient obsolète. Il est gratuit pendant les 6 premiers mois.

Vous trouvez des informations supplémentaires sur les différentes phases d'une version de PHP sur cette page de la 1&1 Community.


Qu'est-ce qu'une version de PHP devenue obsolète ?

Il s'agit d'une version de PHP dont le développement n'est plus assuré par les développeurs de PHP.

C'est le cas pour PHP 4 depuis 2008, pour PHP 5.2 depuis 2011, pour PHP 5.4 depuis septembre 2015 et pour PHP 5.5 depuis juillet 2016.

C'est pourquoi 1&1 doit engager des moyens supplémentaires pour continuer à assurer la sécurité et la maintenance de ces versions alors qu'elles ne sont plus mises à jour par les développeurs.


Pourquoi continuer à proposer une version de PHP devenue obsolète ?

Nous partons du principe que vous pourriez toujours avoir besoin de cette ancienne version de PHP.

Le 1&1 Support Prolongé PHP fait en sorte que les scripts utilisants une version devenue obsolète restent fonctionnels.

Si vous disposez de scripts PHP utilisants une version devenue obsolète, l'option 1&1 Support Prolongé PHP est activée au sein du contrat où se trouvent ces scripts. La date d'activation vous est communiquée dans l'e-mail qui vous est adressé. La mise à disposition de cette option représentant un effort supplémentaire au niveau de l'administration de nos serveurs, cette dernière vous est facturée au tarif indiqué dans l'e-mail.


Ai-je vraiment besoin du 1&1 Support Prolongé PHP ? Comment savoir si mes scripts ne fonctionneraient pas avec une version actuelle de PHP ?

Il est possible que des scripts utilisants une version obsolète de PHP soient déjà compatibles avec une version actuelle de PHP.

Suivez les indications fournies dans notre article Comment savoir si mes scripts fonctionnent avec une version actuelle de PHP ? pour le vérifier.


Je dois modifier mes scripts pour les adapter à une version actuelle de PHP, mais je n'aurai pas fini avant la date d'activation du 1&1 Support Prolongé PHP indiquée dans l'e-mail. Que dois-je faire ?

Contactez simplement notre Service Client en indiquant que vous avez besoin de plus de temps.


Je dispose d'un script utilisant une version obsolète de PHP et je souhaite l'utiliser dans un contrat ne disposant pas de cette dernière. Puis-je ajouter le 1&1 Support Prolongé PHP pour cette version de PHP ?

Le 1&1 Support Prolongé PHP n'est disponible que sur les contrats existants pour lesquels l'utilisation de la version obsolète de PHP a été constatée avant que celle-ci ait été retirée de nos offres.